Jonathon,
Great questions. Here's my go at answers.
The labs under the new objectives haven't really changed much. The primary changes are that RIP is completely gone, and IPv6 is added in. Also, the IOS on the exam is now 15.1 instead of 12.4. If you are running a newer PacketTracer it should have 15.1 already. For the most part, your old PacketTracer labs should still be fine. If you are looking for alternative labs you should check out the
PacketTracer Network. They post labs made by the community and they are really good.
Another great source of study material is the
PacketLife website. The site author has put together some of the best study sheets available and they are completely free.
In just a few days we will be announcing our partnership with
MeasureUP to offer all of our subscribers access to MeasureUP practice exams at no extra charge. Look for that announcement by the end of the week.
A while ago I made a list of all the commands necessary for the CCENT exam. I've been wanting to sit down, update it and post it to the site, but for now, here it is:
enable - Moves the user to the privileged mode user prompt
disable - Moves the user to the unprivileged usermode prompt
? - Displays context sensitive help
e? - Displays commands that begin with the letter "e"
show ? - Displays modifiers for the show command (e.g. show version)
--More-- Prompt:
Enter - Moves ahead one line
Space - Moves ahead one screen
Q - Stops display
show version - Display router/switch hardware and software information
show history - Display a list of commands that have been typed
Up Arrow / Ctrl-P - Scroll through previous commands
Down Arrow / Ctrl-N - Scroll through next commands
Left Arrow / Ctrl-B - Move backward one space
Right Arrow / Ctrl-F - Move forward one space
Home / Ctrl-A - Move to the begining of a command
End / Ctrl-E - Move to the end of a command
reload - Reboot the router or switch
show clock - Display current device time
clock set - Set the current device time
configure terminal - Allows us to modify the currently running configuration
configure memory - Allows us to modify the configuration that will be used the next time we reboot
**running-config **- What is running on the device right now.
startup-config - What will be loaded at boot time.
end / Ctrl-Z - Exit configuration completely
**dir **- Displays the files in flash memory
**dir nvram: **- Displays the files in non-volatile RAM.
**hostname **- Sets the hostname of the device
copy running-config startup-config - Saves the configuration
copy run start - Abbreviated version of the above command
write memory - Saves the configuration (Do not use on the exam)
wr - Abbreviated version of the above command
show running-config - Dislpays the currently running configuration
show startup-config - Displays the configuration that will be used at boot time
clock set - Sets the time (from the privileged mode prompt)
clock set timezone - Sets the timezone (from the configuration prompt)
**clock summertime recurring **- Enables daylight savings time
show log - Displays the error and message logs
interface (e.g. interface fa0/1) - Moves to interface configuration mode
shutdown - Disables a switch or router interface
no shutdown - Enables a switch or router interface
show ip interface brief - Display a summary of all interfaces and their current status
enable password - Sets an unencrypted privileged mode password
enable secret - Sets an MD5 encrypted privileged mode password
line vty 0 15 - Enters line configuration for VTY (Telnet) lines
password - Assigns a password to the VTY lines
interface vlan1 - Moves into the configuration for a switch's virtual interface
ip address [address] [subnet mask] - Assigns an IPv4 address to an interface
show ip route - Display the IPv4 routing table
ip route [network] [subnet mask] [destination] - Add a static IPv4 route to a router
ip route 0.0.0.0 0.0.0.0 [destination] - Add a "Gateway of Last Resort" or default gateway to a router
** NOTE: Destination can be an IP address or an interface name
ip address dhcp - Set an interface to obtain an IP address via a DHCP server on the network
ipv6 address [address]/[subnet bits] - Assigns an IPv6 address to an interface
show ipv6 route - Display the IPv6 routing table
ipv6 route [network]/[subnet bits] [destination] - Add a static IPv6 route to a router
interface loopback0 - Creates a virtual interface useful for testing.
clear ip route - Removes a single route from the routing table.
clear ip route * - Removes all routes from the routing table.
ctrl-shift-6 - Keyboard shortcut to break out of a command that is stuck. Similar to ctrl-c on a PC.
show ip ssh - Displays whether SSH is supported and enabled.
show ssh - Displays current SSH sessions if any.
ip domain-name [name] - Sets a DNS domain name suffix for the device.
crypto key generate rsa - Generates an RSA certficiate for SSL or SSH use. A 1024 bit or higher key modulus is required for SSH v2.
username privilege 15 secret [password] - Creates a user account with administrative privileges.
ssh -l [username] [host] - Connects to another host using SSH
show line - Displays all VTY and AUX lines along with their current status.
show users - Displays all telnet and SSH sessions along with their usernames.
transport input ssh - Disables all connection methods on a VTY line aside from SSH.
show cdp - Displays whether CDP is globaly enabled on the router or switch.
show cdp interface [interface] - Displays whether CDP is enabled on an individual interface.
show cdp neighbors - Displays a list of all directly connected Cisco devices discovered via CDP.
show cdp neighbors detail - Displays detailed information about all neighbors including IP address and IOS version.
show cdp entry [name] - Displays detailed information about a particular neighbor including IP address and IOS version.
(no)cdp run - Enables/Disables CDP globaly on the router or switch.
(no)cdp enable - Enables/Disables CDP on a particular interface on the router or switch.
erase startup-config - Erases the contents of the NVRAM resetting the device to factory defaults on the next reboot.
copy tftp: flash: - Copies a file from a TFTP server into the flash memory of a device.
copy flash: tftp: - Copies a file from the flash memory of a device onto a TFTP server.
switchport mode access - Sets a switchport to non-trunking mode.
switchport access vlan [#] - Sets a switchport to function on a particular VLAN.
vlan [#] - Creates a VLAN with the assigned number.
switchport port-security mac-address [mac] - Statically maps a MAC address to a port.
switchport port-security mac-address sticky - Allows the switch to convert the currently learned MAC address on a port from dynamic to static.
switchport port-security maximum [#] - Sets the maximum number of MAC addresses allowed on the port.
router ospf [process ID] - Enables OSPF on the router.
router-id [ID] - Sets the ID number for the router. It is a 32-bit number represented as an IP address, but it does not have to be an IP address. For example, 0.255.0.0 is a valid Router ID.
network [subnet] [wildcard mask] area [#] - Enables interfaces matching the subnet/wildcard to participate in the OSPF area.
passive-interface [interface] - Allows an interface's subnet to be advertised into OSPF, but prevents the interface from actually participating. No networks will be learned or advertised in or out of the interface.
ip ospf [process ID] area [#] - When issued on an interface, forces that interface to participate in OSPF regardless of IP.
debug ip ospf adj - Display debug information regarding neighbor/adjacency activity in OSPF.
debug ip ospf events - Display debug information relating to all activity in the OSPF process.
undebug all - Disables all debugging
show ip protocols - Displays any actively running IPv4 dynamic routing protocols on the router.
show ipv6 protocols - Displays any actively running IPv6 dynamic routing protocols on the router.
Hope that helps,
Don Pezet
Host, ITProTV